This second part of our series on Deploying Storage Spaces Direct will focus on the core Switch Configurations.

For this blog post series, we have chosen to use Cisco Nexus Switches and given the running configuration.

Obviously, not everyone is going to be using Cisco Switches for their infrastructure. The nice thing about this

post is that it is easy enough to configure other switches with a good running config example.

 

So let’s get started then….

 

Cisco Nexus 9372x Switch Configuration

Windows 2016 uses a feature called SMB Direct, which supports the use of network adapters that have RDMA capabilities. Network adapters that support RDMA can function at full speed with very low latency, while using very little CPU. When used for workloads like Hyper-V or SQL Server this can actually resemble locally attached storage.

 

All of the components listed earlier in this Blog Post support SMB Direct and RDMA. So, let’s go ahead and proceed with the switch configuration. If you remember SET teaming doesn’t support LACP also known as EtherChannel. So, we will configure the Switch Ports as trunk ports only.

We will use the following VLAN’s in this configuration:

 

VLAN

VLAN Name

VLAN Description

2

VLAN2-Backup

Backup and Replication

4

VLAN4-SMB3

SMB3 Dedicated VLAN

8

VLAN8-LiveMigration

Hyper-V Live Migration

9

VLAN9-CSV

Cluster Communication

10

VLAN10-MGMT

Management VLAN

 

 

# Create VLANs the for Switches

SWITCH#configure terminal

SWITCH(config)#vlan 2

SWITCH(config-vlan)#name VLAN2-Backup

SWITCH(config-vlan)#exit

SWITCH(config)#vlan 4

SWITCH(config-vlan)#name VLAN4-SMB3

SWITCH(config-vlan)#exit

SWITCH(config)#vlan 8

SWITCH(config)#name VLAN8-LiveMigration

SWITCH(config-vlan)#exit

SWITCH(config)#vlan 9

SWITCH(config-vlan)#name VLAN9-CSV

SWITCH(config-vlan)#exit

SWITCH(config)#vlan 10

SWITCH(config-vlan)#name VLAN10-MGMT

SWITCH(config-vlan)#exit

# Assigning IP addresses to VLANs

SWITCH#configure terminal

SWITCH(config)#interface vlan 10

SWITCH(config-if)#ip address 10.0.10.212 255.255.255.0

SWITCH(config-if)#exit

# Assigning SWITCH1 Interfaces to VLANs

switch#configure terminal

switch(config)#Interface Ethernet1/1

switch(config-if)#description S2D Node A – Riser P1

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)# switchport trunk native vlan 10

switch(config-if)# switchport trunk allowed vlan 2 to 10

switch(config-if)# switchport mode trunk

switch(config-if)#no shut

switch(config-if)#exit

switch(config)#Interface Ethernet1/2

switch(config-if)#description S2D Node B – Riser P1

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)# switchport trunk native vlan 10

switch(config-if)# switchport trunk allowed vlan 2 to 10

switch(config-if)# switchport mode trunk

switch(config-if)#no shut

switch(config-if)#exit

switch(config)#Interface Ethernet1/3

switch(config-if)#description S2D Node C – Riser P1

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)# switchport trunk native vlan 10

switch(config-if)# switchport trunk allowed vlan 2 to 10

switch(config-if)# switchport mode trunk

switch(config-if)#no shut

switch(config-if)#exit

switch(config)#Interface Ethernet1/4

switch(config-if)#description S2D Node D – Riser P1

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)# switchport trunk native vlan 10

switch(config-if)# switchport trunk allowed vlan 2 to 10

switch(config-if)# switchport mode trunk

switch(config-if)#no shut

switch(config-if)#exit


 

# Assigning SWITCH2 Interfaces to VLANs


 

switch#configure terminal

switch(config)#Interface Ethernet1/1

switch(config-if)#description S2D Node A – Riser P2

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)# switchport trunk native vlan 10

switch(config-if)# switchport trunk allowed vlan 2 to 10

switch(config-if)# switchport mode trunk

switch(config-if)#no shut

switch(config-if)#exit

switch(config)#Interface Ethernet1/2

switch(config-if)#description S2D Node B – Riser P2

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)# switchport trunk native vlan 10

switch(config-if)# switchport trunk allowed vlan 2 to 10

switch(config-if)# switchport mode trunk

switch(config-if)#no shut

switch(config-if)#exit

switch(config)#Interface Ethernet1/3

switch(config-if)#description S2D Node C – Riser P2

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)# switchport trunk native vlan 10

switch(config-if)# switchport trunk allowed vlan 2 to 10

switch(config-if)# switchport mode trunk

switch(config-if)#no shut

switch(config-if)#exit

switch(config)#Interface Ethernet1/4

switch(config-if)#description S2D Node D – Riser P2

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)# switchport trunk native vlan 10

switch(config-if)# switchport trunk allowed vlan 2 to 10

switch(config-if)# switchport mode trunk

switch(config-if)#no shut

switch(config-if)#exit

 

For the final configuration, we will configure an Inter-Switch Link (ISL) between our pair of switches to support the redundant cabling configuration. These will be connected using 2 x of the 40 Gbps QSFP+ cables.

Well folks that is where we will leave part #2 of this blog post. In the next post we will show you how to configure your Mellanox CX3-Pro Adapters with QoS and RMDA Configurations.

 

Thanks,

 

Cristal

 

Cristal Kawula

Cristal Kawula is the co-founder of MVPDays Community Roadshow and #MVPHour live Twitter Chat. She was also a member of the Gridstore Technical Advisory board and is the President of TriCon Elite Consulting. Cristal is also only the 2nd woman in the world to receive the prestigious Veeam Vanguard award.

 

BLOG: http://www.checkyourlogs.net

Twitter: @supercristal1